Hetzner - DokuWiki

Softwareupdate2019/en
(Software updates)
 
Zeile 37: Zeile 37:
 
| PostgreSQL
 
| PostgreSQL
 
| 9.6
 
| 9.6
 +
| -> 11
 +
|-
 +
| Java OpenJDK
 +
| 8
 
| -> 11
 
| -> 11
 
|}
 
|}
Zeile 43: Zeile 47:
 
*[https://packages.debian.org/stretch/ https://packages.debian.org/stretch/] (old version)
 
*[https://packages.debian.org/stretch/ https://packages.debian.org/stretch/] (old version)
 
*[https://packages.debian.org/buster/ https://packages.debian.org/buster/] (new version)
 
*[https://packages.debian.org/buster/ https://packages.debian.org/buster/] (new version)
 
  
 
==Additional changes==
 
==Additional changes==

Aktuelle Version vom 18. Oktober 2019, 13:45 Uhr


Software update for managed servers and web hosting accounts 2019

This page summarizes changes that are the result of the 2019 software update to all web hosting accounts and managed servers.


Software updates

Please note that the version of all PostgreSQL databases will increase from 9.6 to 11 during the update. The MySQL server version will remain unchanged (5.7).

If your databases are affected, you should check beforehand whether your applications are compatible with these versions. They usually are compatible.

Other software updates include the following products:

Package Old -> New
Apache 2.4.25 -> 2.4.38
Git 2.11 -> 2.20
Perl 5.24 -> 5.28
Python
2.7.13
3.5.3
-> 2.7.16
-> 3.7.3
PostgreSQL 9.6 -> 11
Java OpenJDK 8 -> 11

You can search for further changes in Debian packages here:

Additional changes

PHP
/usr/bin/php calls PHP 7.3 (7.2 before). If you need a special PHP version, you should always call the necessary PHP interpreter directly.
Dovecot replaces Courier
Dovecot will replace the POP3 and IMAP service Courier. The advantages of this change are better performance and reliability.
TLS 1.3
TLS 1.3 will be supported for encrypted connections after the update to Debian 10/Buster. TLS 1.3 offers faster connection establishment, better security and improved performance over TLS versions "1.0"-"1.2".
OpenSSL 1.0
OpenSSL 1.0 will no longer be supported. If you have software that uses OpenSSL 1.0, it may have to be adapted and recompiled. If your software uses OpenSSL, please check for necessary changes.
mod_brotli
After the update, our systems will provide support for mod_brotli. You will be able to activate this function via konsoleH.


© 2019. Hetzner Online GmbH. Alle Rechte vorbehalten.